【msys2】更新したら「-bash: getent: コマンドが見つかりません」エラー(パッケージのダウングレード方法)

スポンサーリンク
728×90 ビッグバナー

msys2で2017/1/31にpacman -Syuで更新したら、コンソール起動すると下記エラーを表示してプロンプトが#になるようになった。

-bash: getent: コマンドが見つかりません

それで、pacman -S getentでgetentパッケージをインストールしても、下記エラー。

C:/msys64/usr/bin/getent.exe: error while loading shared libraries: msys-argp-0.dll: cannot open shared object file: No such file or directory

filesystemパッケージが更新されたのが要因のよう。ググってもよく判らないので、とりあえず下記手順でfilesystemパッケージを一つ前にダウングレード。
その前に、pacman -R getentでgetentパッケージは削除。

処置

filesystemパッケージをダウングレードする。

# cd /var/cache/pacman/pkg
# ls -l filesystem*.*
-rw-r--r-- 1 xxxx なし  37028 5月  27  2016 filesystem-2016.05-2-x86_64.pkg.tar.xz
-rw-r--r-- 1 xxxx なし  38264 7月  19  2016 filesystem-2016.07-2-x86_64.pkg.tar.xz
-rw-r--r-- 1 xxxx なし  39908 1月  30 19:55 filesystem-2017.02-1-x86_64.pkg.tar.xz

# pacman -U filesystem-2016.07-2-x86_64.pkg.tar.xz
パッケージをロード...
警告: パッケージ filesystem のダウングレード (2017.02-1 => 2016.07-2)
依存関係を解決しています...
衝突するパッケージがないか確認しています...

パッケージ (1) filesystem-2016.07-2

合計インストール容量:  0.09 MiB
最終的なアップグレード容量:  0.00 MiB

:: インストールを行いますか? [Y/n] y
(1/1) キーリングのキーを確認                       [#####################] 100%
(1/1) パッケージの整合性をチェック                 [#####################] 100%
(1/1) パッケージファイルのロード                   [#####################] 100%
(1/1) ファイルの衝突をチェック                     [#####################] 100%
(1/1) 空き容量を確認                               [#####################] 100%
:: パッケージの変更を処理しています...
(1/1) ダウングレード filesystem                    [#####################] 100%

      WARNING: the shell starting scripts have been unified. Please update your
      shortcuts to the following targets, otherwise they will STOP WORKING:

          * MSYS2_ROOT\msys2_shell.cmd -mingw32
          * MSYS2_ROOT\msys2_shell.cmd -mingw64
          * MSYS2_ROOT\msys2_shell.cmd -msys

#

これでとりあえず、エラーは出なくなりましたが、なにか判ったら報告します。情報をお持ちの方は教えて頂ければ幸いです。

<2017/2/1 追記>

sucarさんからコメント頂きました。本問題は修正版が出たようで、pacman -Syuを再度実行すると解消しました。

補足

  • pacmanの更新記録は/var/log/pacman.logに記録されている。
  • 更新でダウンロードしたパッケージは/var/cache/pacman/pkg/フォルダに保存されている。

参照記事

参考

  1. pacmanダウングレード – Linuxメモ
  2. pacman – ArchWiki
  3. MSYS2の更新に伴う起動用ショートカットの修正 – Qiita
スポンサーリンク
レシポンシブ広告
レシポンシブ広告

シェアする

フォローする

コメント

  1. sucar より:

    同じ症状がでましたが
    6時間前に
    filesystem-2017.02-2-x86_64.pkg.tar.xz.sig
    が出てるようです
    再度 pacman -Syu で直りました

  2. jr4qpv より:

    >sucarさん
    私も先ほど試したらOKになりました。今までは、msys2の更新では不具合はなかったのですが今後は慎重にしようと思います。
    ご連絡ありがとうございました。